[TE4] Modding Problems

Everything about Modding the game, from new courts to the modifications of the player & tournament bases (and including all the bugs they may be creating ! ;) )

[TE4] Modding Problems

Postby Tincho18 » 01 Oct 2021, 18:50

Hi manutoo I am having some issues when modding the game, so i would like to know if im doing something wrong.

First, when changing a 2D Court made for TE2013, i dont know why but in order to make the lines be in the right place, i have to put aspect ratio to 16:10, and that deform the photo.

When trying to Add sounds i copied my sounds folder from a TE2013 Mod in my TE4 mod, and tried putting sound.ini in that folder, also putting it in specifics/ini folder, changing its name to sound_mod.ini but it never worked. It crashes at sound 11 or there is no sound.

With today Outfit modding SDK, i tried to add shirts but the number of shirts options in the game never changed although i changed the NbType in GameSys_Mod.ini. Also, i tried to add rackets but it seems like default racket hide the modded one because in some parts of the racket i can see the modded part but in most parts of the rackets surface the texture is the default one.

Sorry for so many questions
Thanks manutoo
You do not have the required permissions to view the files attached to this post.
Tincho18
crazy of the little yellow ball
crazy of the little yellow ball
 
Messages: 50
Gaming Since: 09 Jun 2021, 01:53

Re: [TE4] Modding Problems

Postby manutoo » 02 Oct 2021, 06:08

Hello,

1) Did you read the "2D Court" section here : topic11-31376.php ? Especially the "/!\ Note for TE2013 2D Courts " ; I guess it's your issue.

2) Check your Player.log for error & warning about the sounds.

3) You don't have to touch the GameSys.ini to add outfit. Put them in the correct folder and it should work.
ManuTOO
== Mana Games ==

>> I don't answer Private Message, except if it's really a _Private_ topic <<
User avatar
manutoo
Game Author
 
Messages: 17497
Gaming Since: 24 Jan 2004, 15:38
Location: France

Re: [TE4] Modding Problems

Postby Tincho18 » 02 Oct 2021, 22:21

Thanks Manutoo!
Right thatsmy issue with the courts
The outfit i can see it now but i think that as my image is from TE2013, it`s shown very small.
Also, the racket texture its different as the one from TE2013, now its divided in parts, isnt it?
The sounds i looked into it and the error i get its that the game cant find MenuIn MenuOut sounds, but they are in the sounds folder and also in Sound.ini

Thanks again! The game keeps going better and better, cant wait for a mod like Sam Patch one day :applause:
Tincho18
crazy of the little yellow ball
crazy of the little yellow ball
 
Messages: 50
Gaming Since: 09 Jun 2021, 01:53

Re: [TE4] Modding Problems

Postby manutoo » 03 Oct 2021, 08:40

1) Yes, the texture sizes & arrangements all changed ; you cannot copy over your racket textures from TE2013

2) You shouldn't use the Sound.ini from TE2013 without any change ; at least copy over the [Menu] section from the TE4 Sound.ini . (I guess :blackeye: )
ManuTOO
== Mana Games ==

>> I don't answer Private Message, except if it's really a _Private_ topic <<
User avatar
manutoo
Game Author
 
Messages: 17497
Gaming Since: 24 Jan 2004, 15:38
Location: France


Return to Modding - TE4

Who is online

Users browsing this forum: CCBot [Bot] and 2 guests