Crash at startup due to surface issue ?

the place to report any bug met in the game

Crash at startup due to surface issue ?

Postby Post » 01 Jan 2013, 12:19

Hello and Happy New Year,

For almost 2 days, my game crashes at startup with the usual message referring to System.log. Then I deleted my Tennis.ini file and the game worked fine again. But the problem has come back, so I've checked my Tennis.ini file and realized that the problem is related to five lines :

Surface_Fast = 23.2006
Surface_MidFast = 74.4514
Surface_MidSlow = 73.9689
Surface_Normal = 94.7451
Surface_Slow = 25.3949

These parameters are the ones from my Player 2 (Federer) in the Training Club. If I change one of these numbers for an integer, the game does not crash anymore at startup. I encountered this problem with Federer only but I presume some other players are in the same case.

I precise that I have modded myself my game with new courts, but it has never caused any problem until last week-end. Obviously the issue is related to the speed of my new courts. Does anyone know how to fix it ?
Post
tennis fan
tennis fan
 
Messages: 17
Gaming Since: 12 Oct 2012, 13:08

Re: Crash at startup due to surface issue

Postby manutoo » 02 Jan 2013, 05:34

Hello,

post your System.log .
Check the SurfaceSpeed in all your Court.ini are within the [-1;+1] range.
ManuTOO
== Mana Games ==

>> I don't answer Private Message, except if it's really a _Private_ topic <<
User avatar
manutoo
Game Author
 
Messages: 15583
Gaming Since: 24 Jan 2004, 15:38
Location: France

Re: Crash at startup due to surface issue

Postby Post » 02 Jan 2013, 20:58

Hi,

You will find attached my System.log file with the crash report.

Regarding the surfaces' speeds, I've checked them and they all range from -1.0 to 1.0.
Attachments
System.Log
(25.5 KiB) Downloaded 10 times
Post
tennis fan
tennis fan
 
Messages: 17
Gaming Since: 12 Oct 2012, 13:08

Re: Crash at startup due to surface issue

Postby manutoo » 03 Jan 2013, 05:36

Issue is with the Sound Init.
If you modded the sounds, it may come from that, or it could be faulty sound drivers.
ManuTOO
== Mana Games ==

>> I don't answer Private Message, except if it's really a _Private_ topic <<
User avatar
manutoo
Game Author
 
Messages: 15583
Gaming Since: 24 Jan 2004, 15:38
Location: France

Re: Crash at startup due to surface issue

Postby Post » 05 Jan 2013, 01:45

That's it, there was a glitch in my Sound.ini. Many thanks :wink: .
Post
tennis fan
tennis fan
 
Messages: 17
Gaming Since: 12 Oct 2012, 13:08


Return to TE - Bug Report

Who is online

Users browsing this forum: No registered users and 1 guest